Ad Space here

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Share
Options
Go to last post Go to first unread
Dustin Higgins  
#1 Posted : Monday, October 14, 2019 3:34:53 PM(UTC)
Dustin Higgins

Rank: Advanced Member

Groups: Registered
Joined: 7/1/2018(UTC)
Posts: 60
_United States

Thanks: 1 times
Was thanked: 6 time(s) in 6 post(s)

Folks have been complaining about Windows 10 printers not showing up in the "Printers & Scanners" GUI on our Windows 10.  If you go into Notepad to print, the printers are listed there and work fine.  This is very confusing for the users.  I did some searches and it appears that I'm not the only one with the issue.  Does anyone know how to fix?

Sponsor
Ad Space here
Dustin Higgins  
#2 Posted : Monday, October 14, 2019 5:25:17 PM(UTC)
Dustin Higgins

Rank: Advanced Member

Groups: Registered
Joined: 7/1/2018(UTC)
Posts: 60
_United States

Thanks: 1 times
Was thanked: 6 time(s) in 6 post(s)

It seems that the printers do indeed show up after a reboot.

Dustin Higgins  
#3 Posted : Tuesday, October 15, 2019 8:53:27 AM(UTC)
Dustin Higgins

Rank: Advanced Member

Groups: Registered
Joined: 7/1/2018(UTC)
Posts: 60
_United States

Thanks: 1 times
Was thanked: 6 time(s) in 6 post(s)

After creating the following reg key and rebooting:

{2227a280-3aea-1069-a2de-08002b30309d} had to be created.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\{2227a280-3aea-1069-a2de-08002b30309d}

Value: Default

Data: Printers

A "Printers" icon showed up on the desktop.  New printers show up here but not in the "Printers & Scanners" GUI that is under settings for Windows 10 computers.  It is kind of hit or miss whether or not the printers show up in the "Printers & Scanners" GUI in a timely manner.  I think we will just install the reg key and have the users use the "Printers" shortcut that is on the desktop.

Thanks,

Dustin

Dustin Higgins  
#4 Posted : Tuesday, October 15, 2019 2:35:06 PM(UTC)
Dustin Higgins

Rank: Advanced Member

Groups: Registered
Joined: 7/1/2018(UTC)
Posts: 60
_United States

Thanks: 1 times
Was thanked: 6 time(s) in 6 post(s)

This will make the old printers box show up also (handy to have):

c:\windows\explorer.exe ::{2227A280-3AEA-1069-A2DE-08002B30309D}

The problem that I had was actually with permissions on the C:\Windows\Temp folder.

gwmi win32_printer was failing with a COM error.  Procmon showed permission denied trying to get to the C:\Windows\Temp folder.   I added the users group full control to the Temp folder and the printers started showing up.  It also fixed the gwmi win32_printer problem.

Dustin Higgins  
#5 Posted : Thursday, October 24, 2019 12:30:41 PM(UTC)
Dustin Higgins

Rank: Advanced Member

Groups: Registered
Joined: 7/1/2018(UTC)
Posts: 60
_United States

Thanks: 1 times
Was thanked: 6 time(s) in 6 post(s)

Printers in Windows 10 are generally a nightmare!  I also found out that creating a folder named "Printers.{2227A280-3AEA-1069-A2DE-08002B30309D}" is another way to get to the old functional printers folder.  Running Windows 10 Build 1903. 

Rss Feed  Atom Feed
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.